Workspace locked

I have an error that is not allowing me to use the app. it says workspace locked due to being hosted on regional server. Please upgrade or switch workspace. I only have 1 workspace on my app. Any help appreciated.

Hello Jane, welcome to the Clockify forum!

Could you kindly reach out to us at so we can look into this further and troubleshoot it with you?


I have the identical error message recently appear regarding the “workspace is locked due to being hosted on regional server, etc.” I have made no changes to my system. Please reply with the fix. Thanks.

Try to log out and back in again in the app. Solved it for me.


The error message suggests that an upgrade or migration might be needed. Check if there are any instructions or options provided for upgrading your workspace to a non-regional server or migrating it to a different server. Follow these instructions if available.

Registered just to say thank you - this solved my issue! I was recently om holiday in the States and now back home, not sure if that was a potential trigger but glad to have it sorted.

1 Like

Hello All,

We had some issues where android users where experiencing a “Locked workspace” within the newest update 2.8.0.

The issue was indeed fixable with simple log out/log in or by reinstalling the app (which also requires you to log out)

The dev team released a fix and there should be no issues at all now.

The locked workspace will only appear if the workspace is hosted on any of our regional servers which is available only for Standard and Pro subscription plans and in case you experience it on a Global server, please contact the Support at so we can check it out.