Clockify opens taskbar when timing


The latest update to Clockify for Windows has introduced a very annoying feature! I use Winodws with the taskbar auto-hidden. As soon as Clockify loses focus, ie you start work on the item you are timing, it starts flashing a pink background on the taskbar icon, which causes the taskbar to pop-up, often over the task I am working on.

I cannot find a way of stopping this - please could you either turn it off, or at least provide a way of making it optional.



Further experimentaiton reveals that turning off “Keep on top” stops this behaviour, but then the clockify timer - obviously - gets hidden.

I normally have Clockify set to stay on top and I’m pretty sure that the taskbar remained hidden until recently but as I can’t roll back to check, I can no longer be sure…

Hi @mfwiniberg

Can you please contact so we can investigate this issue further?


Will do. Thanks very much

Further to the above, had a very fast helpful response from support and learnt something new about Windows as a result.

There is under

settings / Personalisation / taskbar / taskbar behaviours

an option to stop flashing icons being displayed, and that prevents the pop-up taskbar when timing with clockify set to always on top.

I’ve been an IT consultant and software dev since the mid 1970s, have used windows since it came into existence and yet I did know of that option in Windows 11. You learn something every day.

Thanks to Milena in support for pointing me in the right direction!