Bug? Keeps counting upon laptop shutdown

tldr: clock keeps counting when i just shut down my laptop, as opposed to explicitly stop the clock, or close my browser.

I didn’t see a place for bugs, so I am trying this ‘Feedback’ category.

This is my second or third time trying Clockify. I end up experiencing this issue then abandon it.

It’s not necessarily easy to track but I’ll try it again now.

Basically, when I just close my laptop lid, my computer shuts down - as expected/wanted. However, this seems to cause the Clockify timer to not be able to shut down - because when I open my laptop again, say 8 hours later, it will tell me that I’ve been working on the same task for 8+ hours, and there doesn’t seem to be an easy way to fix this. But I’d rather it not happen in the first place. I do have that idle timer checkbox checked, and it does seem to work when I’m idle and the laptop is still online (but even that UI/UX has a problem, imo, but that’s a separate topic).

Anyone else seen this?

My current workaround is to try to remember to explicitly stop the timer before I shut my laptop lid.


Hi there,

Can you please let me know what app you are using(web, desktop, or perhaps browser extension)? We do have the option to stop the timer when the computer shuts down or goes to sleep under app preferences(see attached). You can download the desktop app at this link. In case you are using the Clockify extension you can enable the option “Stop timer when browser closes”(see attached).

Hope this helps. If you still experiencing the same issue after enabling the above-mentioned options feel free to contact our Support team at support@clockify.me


yikes, i should have said platform – chrome on desktop windows.

i did just verify the behavior - which i would call a bug, but i could understand the other argument. maybe it’s just a limitation of using the chrome extension, and/or not using the extension correctly.

basically, if i just shutdown my computer, the task keep running/counting. so this shows me running this task for 5 min, then i shut down the laptop by closing the lid for about a half hour, then open/start the laptop again, i have the browser set to auto-start, and clockify is still counting the TestLaptopLidCloseChromeExtension task, and i do get a popup that says, “you’ve been idling for 1 min” - i think this is a side effect of the behavior/bug - and i can choose to discard or discard and continue, but the result is the same - the timer had effectively kept running when i shut down my laptop - which, presumably includes shutting down my browser (i.e. i do have that checkbox checked).

i’ll try the windows app, tho living in the browser is my ideal situation. and i think it could prob be fixed/addressed/made to work with the chrome extension, but would prob require real engineering effort, but might be fun for engrs. :slight_smile:


ok, verified the windows client does what we want/expect.

def feels more cumbersome than the chrome extension but will try it out for a while and see if it’s my thing.


Thank you for updating us @atlguy!

Just a note that Clockify is synced across all of your apps, therefore in case you forget to stop the timer sometimes, you’re also able to stop it from your mobile app or Clockify in mobile browser.

However, timer will automatically be stopped upon shutting off the computer, only if above-mentioned setting is enabled in Windows app.

In case you have any additional questions, feel free to let us know.


Apologies for resurrecting an old thread but I wanted to verify the information provided. If I want the timer to stop when I shut down my computer, I have to uninstall the chrome extension?

Hi @BravuraBooks, thank you for joining the Clockify forum.

Please note that you can set the timer to stop when you shut down your computer on the desktop app. On the extension, though, you can set it up so that the timer stops when the browser is closed [see screenshot Nicola left in the first reply to the thread]

You don’t need to uninstall the extension, but in order to have the option to have the timer stopped on shutdown, you would need to use a desktop app.

I hope this helps! If not, let us know.