Api key does not exist - code 4003


In accessing the new API we get the following error message on all requests
{ “message”: “Api key does not exist”, “code”: 4003 }

We have tried to regenerate our key but we still get the same message.

example of the call we are making:

curl -H “content-type: application/json” -H “X-Api-Key: $apiKey” -X
GET https://developer.clockify.me/api/v1/workspaces/$workSpace/projects

Can you please assist.


Hi there. In this case, the general, publicly available API endpoints should be api.clockify.me rather than developer.clockify.me, which should be the dev stage.

Could you please update the GET method, and let us know if it works as expected?


We are in the process of testing the new new endpoints in the new API.

We are already calling the APIs using " api.clockify.me" and they work fine.

However the new api documentation says that we should be using " developer.clockify.me".
Using the new API we get code: 4003 error.

If I try get all assignments below I get a code 501 error if i leave the dates out, with dates OI get the same 501

curl -H “content-type: application/json” -H “X-Api-Key: $apiKey” -X
GET https://api.clockify.me/api/v1/workspaces/$workSpace/scheduling/assignments/all?start=“2021-01-01T00:00:00Z”&end=“2025-01-01T00:00:00Z” | jq

“You entered invalid value for field : [end]. Values that represent [end] can’t be null and can’t be empty. Please make sure that the [end] date is not greater than 9999-12-31 and not less than 0001-01-01. Ensure that the [end] date is in following format: "yyyy-MM-ddThh:mm:ssZ" Example: 2018-11-29T13:00:46Z.”,“code”:501


  • Are the new endpoints available for use?
  • What am I doing wrong in the above example?



Problem solved …
GET [https://api.clockify.me/api/v1/workspaces/$workSpace/scheduling/assignments/all?start=“2021-01-01T00:00:00Z”**&**end=“2025-01-01T00:00:00Z”

I am using curl on unix.
The & needs to be escaped, i.e. &